Users are experiencing degraded performance on the photo platform.

  • Now
  • Nov 9, 2025, 4:14:14 PM GMT+1
    Resolved

    We have resolved the incident.

  • Nov 9, 2025, 4:04:51 PM GMT+1
    Monitoring

    The incident remains in the monitoring phase as our team continues to work towards full stability for both photo processing and photo viewing services. After implementing a fix, we are closely observing system performance to ensure that all issues have been addressed. Users may notice improvements, and we will provide further updates once we confirm that all services are fully operational.

  • Nov 9, 2025, 4:03:19 PM GMT+1
    Monitoring

    We have fixed the issue and are monitoring the affected services.

    Photo viewing
    Photo processing
  • Nov 9, 2025, 3:39:08 PM GMT+1
    Monitoring

    We have fixed the issue and are monitoring the affected services.

  • Nov 9, 2025, 3:34:43 PM GMT+1
    Identified

    We have identified the root cause for this incident and are fixing it.

  • Nov 9, 2025, 3:32:48 PM GMT+1
    Investigating

    We are currently investigating reports of degraded performance affecting our photo platform. Some users may notice slower load times or reduced functionality when processing or viewing photos. Our engineering team is actively diagnosing the issue to restore full service as quickly as possible. We appreciate your patience and will provide updates as soon as more information is available.

    Photo viewing
    Photo processing