Photo platform experiencing degraded performance affecting photo viewing and processing services

Resolved
Duration: 58mJun 1, 2026

Affected services

Photo viewing

Partial outage

Photo processing

Partial outage

Timeline

Resolved
12:36Jun 1, 202617d ago

We have resolved the incident.

Monitoring
11:59Jun 1, 202617d ago

We have fixed the issue and are monitoring the affected services.

Identified
11:58Jun 1, 202617d ago

We have identified the root cause for this incident and are fixing it.

Investigating
11:51Jun 1, 202617d ago

We are currently investigating this issue.

Photo viewingPhoto processing
Investigating
11:37Jun 1, 202617d ago

We are currently investigating reports of degraded performance affecting the photo platform. Users are experiencing slower than normal response times when viewing and processing photos. Our engineering team is actively monitoring system performance and working to identify the root cause. We will provide updates as we learn more about the issue and its resolution.

Photo viewingPhoto processing