Partial Service Disruption

Resolved
Duration: 6h 9mJun 27, 2026

Affected services

Photo viewing

Degraded

Photo processing

Degraded

Timeline

Resolved
02:53Jun 28, 202618d ago

We have resolved the incident.

Monitoring
21:45Jun 27, 202619d ago

We have fixed the issue and are monitoring the affected services.

Identified
21:38Jun 27, 202619d ago

We have identified the root cause of the ongoing incident. Failing nodes have been successfully isolated to prevent further degradation. However, parts of the platform are still operating at reduced capacity as a result.

Our upstream provider is actively working to restore full service. Users may continue to experience issues during this recovery period. We are closely monitoring the situation and will provide further updates as progress is made.

We apologize for the inconvenience and appreciate your patience.

Identified
21:23Jun 27, 202619d ago

We have identified the root cause for this incident and are fixing it.

Identified
21:08Jun 27, 202619d ago

We are currently investigating an ongoing incident affecting photo-related services. Our team has made progress in isolating the root cause — failed nodes have been identified and isolated due to issues with our upstream provider. We are actively working on remediation steps to restore full service capacity. The affected services remain in a degraded state while we continue to address the underlying infrastructure issues. We will provide further updates as the situation develops.

Investigating
20:44Jun 27, 202619d ago

We are currently investigating an issue affecting a subset of PixelUnion instances. Some users may be unable to access their photo library.

Our team is actively investigating the cause. We will provide an update as soon as we have more information.

Photo viewingPhoto processing