Some Immich backend services are currently not responding, impacting functionality.

  • Now
  • Sep 6, 2025, 9:24:39 PM GMT+2
    Resolved

    We have resolved the incident.

  • Sep 6, 2025, 9:11:53 PM GMT+2
    Identified

    We have identified the root cause for this incident and are fixing it.

  • Sep 6, 2025, 8:51:50 PM GMT+2
    Investigating

    We are currently investigating an issue where some Immich backend services are not responding as expected. This may result in degraded performance or unavailability of certain features for users. Our team is actively working to identify the root cause and restore full service as quickly as possible. We appreciate your patience and will provide updates as soon as more information is available.

    Photo viewing
    Photo processing