Degraded uploading

  • Now
  • Jan 14, 2026, 10:37:47 PM GMT+1
    Resolved

    We have resolved the incident.

  • Jan 14, 2026, 10:27:36 PM GMT+1
    Identified

    We have identified the root cause for this incident and are fixing it.

  • Jan 14, 2026, 10:24:51 PM GMT+1
    Investigating

    We are currently investigating an issue causing slower photo uploads. Some users may notice delays or interruptions when uploading photos. Our team is working to identify the cause and restore normal service as quickly as possible. We appreciate your patience and will provide updates as we learn more.

    Photo processing