Users may experience slow performance or limited functionality on the photo platform.

Resolved
Duration: 30mJan 24, 2026

Affected services

Photo viewing

Degraded

Photo processing

Degraded

Timeline

Resolved
10:22Jan 24, 20266mo ago

We have resolved the incident.

Identified
10:02Jan 24, 20266mo ago

We have identified the root cause for this incident and are fixing it.

Investigating
09:51Jan 24, 20266mo ago

We are currently investigating an issue causing reduced performance on our photo platform. Some users may notice slower load times or limited access to certain features. Our team is working to identify the cause and restore full service as quickly as possible. We appreciate your patience and will provide updates as we learn more.

Photo viewingPhoto processing