Platform instability causing elevated error rates

  • Now
  • Mar 4, 2026, 8:48:24 PM GMT+1
    Resolved

    We have resolved the incident.

  • Mar 4, 2026, 8:44:20 PM GMT+1
    Monitoring

    We have fixed the issue and are monitoring the affected services.

  • Mar 4, 2026, 8:28:52 PM GMT+1
    Identified

    We have identified the root cause for this incident and are fixing it.

  • Mar 4, 2026, 7:37:55 PM GMT+1
    Investigating

    We are currently investigating this issue.

    Photo viewing
    Photo processing