Issue reported on photo storage platform - investigating photo viewing and processing services

Resolved
Duration: 1hMar 1, 2026

Affected services

Photo viewing

Partial outage

Photo processing

Partial outage

Timeline

Resolved
17:27Mar 1, 20261mo ago

We have resolved the incident.

Photo viewingPhoto processing
Monitoring
16:28Mar 1, 20261mo ago

We have fixed the issue and are monitoring the affected services.

Photo viewingPhoto processing
Investigating
16:17Mar 1, 20261mo ago

We are currently investigating an issue affecting our photo storage platform. Users may experience difficulties accessing or processing their photos. Our engineering team is actively working to identify the root cause and restore full functionality. We appreciate your patience and will provide updates as soon as we have more information.

Photo viewingPhoto processing