Photos platform experiencing degraded performance affecting viewing and processing capabilities.

Resolved
Duration: 54mApr 14, 2026

Affected services

Photo viewing

Partial outage

Photo processing

Partial outage

Timeline

Resolved
03:07Apr 14, 20261d ago

We have resolved the incident.

Photo viewingPhoto processing
Identified
02:13Apr 14, 20261d ago

We have identified the root cause for this incident and are fixing it.

Photo viewingPhoto processing
Investigating
02:12Apr 14, 20261d ago

We're currently investigating degradation in our photos platform. Users may experience slower loading times, delays when processing images, or temporary unavailability of photo viewing features. Our engineering team is actively working to identify the root cause and restore full performance. We'll provide updates as soon as we have more information.

Photo viewingPhoto processing