Investigating reports of degraded photo performance affecting photo viewing and processing services.
Resolved
Duration: 8hApr 14, 2026Affected services
Photo viewing
Degraded
Photo processing
Degraded
Timeline
Resolved
19:43Apr 14, 202617h ago
We have resolved the incident.
Photo viewingPhoto processing
Monitoring
11:00Apr 14, 20261d ago
We have fixed the issue and are monitoring the affected services.
Photo viewingPhoto processing
Investigating
10:44Apr 14, 20261d ago
We are currently investigating reports of degraded photo performance. Users may experience slower loading times and delayed processing of photos. Our engineering team is actively diagnosing the root cause and monitoring the affected services. We will provide updates as soon as we have more information. We appreciate your patience during this investigation.
Photo viewingPhoto processing