Platform experiencing instability affecting multiple core services; investigation underway
Resolved
Duration: 12mApr 15, 2026Affected services
Photo viewing
Degraded
Photo processing
Degraded
Provisioning
Degraded
Authentication
Degraded
Migrator
Degraded
Timeline
Resolved
00:11Apr 16, 202616d ago
We have resolved the incident.
Photo viewingPhoto processingProvisioningAuthenticationMigrator
Investigating
00:11Apr 16, 202616d ago
We are currently investigating this issue.
Photo viewingPhoto processingProvisioningAuthenticationMigrator
Investigating
23:58Apr 15, 202616d ago
We are currently investigating reports of instability affecting multiple platform services. Users may experience degraded performance, intermittent connectivity issues, or temporary unavailability across provisioning, authentication, migration, and photo-related services. Our engineering team is actively diagnosing the root cause and working to restore full service stability. We will provide updates as more information becomes available.
Photo viewingPhoto processingProvisioningAuthenticationMigrator