Photo service experiencing degraded performance affecting viewing and processing capabilities

Resolved
Duration: 39mMay 5, 2026

Affected services

Photo viewing

Partial outage

Photo processing

Partial outage

Timeline

Resolved
17:24May 5, 202612d ago

We have resolved the incident.

Photo viewingPhoto processing
Identified
16:46May 5, 202612d ago

We have identified the root cause for this incident and are fixing it.

Photo viewingPhoto processing
Investigating
16:46May 5, 202612d ago

We are currently investigating this issue.

Photo viewingPhoto processing
Investigating
16:44May 5, 202612d ago

We're currently experiencing degraded performance with our photo services. Users may experience slower load times when viewing or processing photos, and some operations might take longer than usual to complete. Our engineering team is actively investigating the root cause and working on a resolution. We appreciate your patience as we work to restore full service performance.

Photo viewingPhoto processing