Elevated error rate detected on photo platform services affecting viewing and processing capabilities

Resolved
Duration: 32mMay 7, 2026

Affected services

Photo viewing

Degraded

Photo processing

Degraded

Timeline

Resolved
00:31May 8, 202623d ago

We have resolved the incident.

Photo viewingPhoto processing
Identified
00:25May 8, 202623d ago

We have identified the root cause for this incident and are fixing it.

Photo viewingPhoto processing
Investigating
23:59May 7, 202623d ago

We are currently investigating an elevated error rate affecting our photo platform services. Users may experience intermittent failures or delays when viewing or processing photos. Our engineering team has been notified and is actively working to identify the root cause. We will provide updates as soon as we have more information.

Photo viewingPhoto processing