Partial Service Disruption
Resolved
Duration: 8mMay 19, 2026Affected services
Photo viewing
Degraded
Photo processing
Degraded
Timeline
Resolved
22:50May 19, 202611d ago
We have resolved the incident.
Photo viewingPhoto processing
Identified
22:41May 19, 202611d ago
We are currently investigating an issue affecting a subset of PixelUnion instances. Some users may be unable to access their photo library.
Our team is actively investigating the cause. We will provide an update as soon as we have more information.
Photo viewingPhoto processing