Partial Service Disruption
Resolved
Duration: 52mJun 14, 2026Affected services
Photo viewing
Partial outage
Photo processing
Partial outage
Timeline
Resolved
16:05Jun 14, 202612d ago
We have resolved the incident.
Identified
15:30Jun 14, 202612d ago
We have previously identified the root cause of this incident affecting our photo-related services. A fix is currently being rolled out and may take a few minutes to fully propagate. We are actively monitoring the deployment and will provide further updates as soon as the situation changes. Thank you for your patience.
Identified
15:16Jun 14, 202612d ago
We have identified the root cause for this incident and are fixing it.
Investigating
15:13Jun 14, 202612d ago
We are currently investigating an issue affecting a subset of PixelUnion instances. Some users may be unable to access their photo library.
Our team is actively investigating the cause. We will provide an update as soon as we have more information.
Photo viewingPhoto processing