Platform instability

Resolved
Duration: 1d 17hSep 3, 2026

Affected services

Photo viewing

Partial outage

Photo processing

Partial outage

Timeline

Resolved
09:49Sep 5, 202617d ago

We have resolved the incident.

Monitoring
22:04Sep 3, 202618d ago

We are continuing to monitor the situation following our recent interventions. Earlier, we identified that high demand was causing capacity issues impacting platform stability for a fraction of our tenants.

As of now, we are in the monitoring phase to ensure that stability is fully restored across all affected tenants. Some services may still be experiencing reduced performance while we confirm the fix is holding.

Monitoring
21:52Sep 3, 202618d ago

We have fixed the issue and are monitoring the affected services.

Investigating
16:13Sep 3, 202619d ago

We are currently investigating an issue affecting a subset of PixelUnion instances. Some users may be unable to access their photo library.

Our team is actively investigating the cause. We will provide an update as soon as we have more information.

Photo viewingPhoto processing